Home
Downloads
Community
Submit
Marketplace

Some games opening sideways in full screen

Come here if you are having PC gaming related issues

Some games opening sideways in full screen

Postby mynamedoesntmatter » Fri Nov 24, 2017 8:35 pm

Ok, so I have a Windows 10 tablet (by a company called NuVision I think). Some games (ie Project 64, Simpsons Hit and Run) open sideways (see picture for reference). I have the screen rotated to 240° so it's sideways and these games open in 0° in full screen no matter what. Now from what I know there's two ways to fix it:

1) Setting the screen rotation to 0°, not tapping keep changes, double tap the game and hope it opens before it reverts back to 270°. If it does, it'll revert back to 270° while in game, and the game screen will flip with it. This would be easier if I had a keyboard for my tablet but I don't so this is unreliable and hard to do.

2) Some how tricking the tablet into thinking 270° rotation is actually 0° rotations, since the games open at 0° rotation, this should fix the issue.


I need help doing the ladder, is there anyway to have 270°=0°? I know it's a longshot but sometimes you can do some registry trickery so if any of you guys can help me out that would be great.
  • 0

You do not have the required permissions to view the files attached to this post.
I know a guy that knows a guy that knows a guy that knows a website whos founder knows a robot whos creator knows a lizerd whos owner knows another guy who knows you.
User avatar
mynamedoesntmatter 2
 
Posts: 38
Joined: Sun Nov 29, 2015 5:58 pm
Reputation: 70

Re: Some games opening sideways in full screen

Postby kaos_engr » Fri Nov 24, 2017 9:55 pm

There's may be a conflict between the auto-screen rotate function software driver of the tablet and the game's video driver.

Can the screen flipping/rotating software/driver be disabled?

Update: Just googled it and found this Windows 10 Auto rotatation disabled page:

Use the following steps to turn off this feature.

1. Place the tablet into Pad/Tablet mode.
2. Click the Start menu and select Settings.
3. Click System.
4. Click Display.
5. Scroll down and toggle Lock rotation of this display to OFF.


And this page too Why is my computer screen upside down or rotated 90 degrees?

Update 2: The first URL wasn't working. :( It was missing a character. '0' at the end of the URL -- fixed. :D
  • 0

User avatar
kaos_engr 6
 
Posts: 891
Joined: Wed May 16, 2012 1:27 am
Reputation: 3043

Re: Some games opening sideways in full screen

Postby HisDivineShadow » Sat Nov 25, 2017 12:05 am

You can get this sort of problem in-game too if the Default Hotkeys for rotation of the screen image are, by default or accidentally user assigned to a game's character movement.

The original TR had the controls for Action, Jump and Movement assigned to CRTL, ALT and Directional keys which were used as Hotkeys by later Windows OS for rotating the screen image. So when you use the guns and jump from side to side the screen image can suddenly rotate.

Very disconcerting when it first happens and you do not know why.

As kaos_engr has said the solution is simple: depending on the Windows version turn off the rotation option or the Hotkeys. For the latter: on an empty part of the desktop right click and choose Graphics Options > Hotkeys and select Disable.

If you use on board Intel Graphics you can choose the Graphic Properties from the right click menu instead then click Options and Support to see the Hotkey assignments and disable them there too. However there does not seem to be any way of just disabling rotation specifically, it is all hotkeys enabled or disabled.

That you can't disable specific hotkeys is a surprising omission.
  • 0

User avatar
HisDivineShadow 9
 
Posts: 2227
Joined: Sat Jun 15, 2013 3:27 pm
Reputation: 4151

Re: Some games opening sideways in full screen

Postby mynamedoesntmatter » Sat Nov 25, 2017 3:08 pm

Thank you both, but sadly, none of your advice helped. Like I said, the problem is that these games always open in the 0° rotation, so locking rotation wouldn't help becuase it's still in the 270° rotation. Also, I'm using a controller, so it can't be a hotkey issue, also, it happens at launch.
  • 0

I know a guy that knows a guy that knows a guy that knows a website whos founder knows a robot whos creator knows a lizerd whos owner knows another guy who knows you.
User avatar
mynamedoesntmatter 2
 
Posts: 38
Joined: Sun Nov 29, 2015 5:58 pm
Reputation: 70


Return to Troubleshooting



Who is online

Users browsing this forum: No registered users and 7 guests



Home | Legal Notice | DMCA Policy | DMCA File Removal Center | Contact